The Europe server access issue has been successfully resolved after identifying and addressing the root cause. Document and user account processing have returned to normal speeds, ensuring all customers can export projects without disruption. No data was lost during the incident. Our engineering team has confirmed the fix is in place, and we continue to monitor the system to ensure stability.
Kindly recommend clearing your browser cache should you continue to experience issues on your side. We appreciate your understanding and patience.
Posted Jul 20, 2026 - 12:19 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 19, 2026 - 17:46 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 19, 2026 - 10:42 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 19, 2026 - 10:41 UTC
Identified
We are aware that users experienced difficulties accessing the Smartcat Page, as the sign-in functionality was unavailable overnight. At present, Webtranslation and BI services remain affected, and sporadic disruptions are impacting other tools across the system.
We sincerely apologize for the inconvenience this has caused. Our engineering team is actively working to restore full functionality and resolve the issue as quickly as possible. Further updates will be shared here as progress continues.