Performance degradation on EU Platform

Incident Report for Smartcat

Resolved

The incident has been resolved. All systems are operating normally again.

Thank you for your patience and understanding.
Posted Jul 21, 2026 - 15:22 UTC

Investigating

We are currently investigating an issue causing slowness and service degradation on our EU platform.
Impact:
Delays and errors in project task creation, assignment, and completion
Tasks not appearing in newly created projects
Discrepancies in project tasks when pushing files via API
Our engineering team is actively working on identifying the root cause. We will provide updates as soon as more information is available.
Posted Jul 21, 2026 - 12:31 UTC
This incident affected: European region.