We have now reached peak processing capacity for reindexing activities. Based on the current processing rate, we expect reindexing to be completed by end of day April 17, 2026. In parallel, we are actively working on additional adjustments to safely increase indexing throughput and further accelerate recovery where possible.
System performance continues to improve, and new activity remains prioritized to minimize disruption. The remaining reindexing is primarily related to TM units in segments from older projects and should not block assignment workflows.
We will continue to monitor progress closely and provide further updates as needed.
Posted Apr 15, 2026 - 22:06 UTC
Update
We are continuing to investigate this issue.
Posted Apr 13, 2026 - 16:01 UTC
Update
We have identified the root cause and deployed a fix, with system recovery now underway and accelerating. Performance is steadily improving, and we have reports that some users have already resumed normal work.
We are continuing to restore full performance while prioritizing new activity to minimize disruption - we expect full resolution by April 15, 2026, but you should already notice improvements in new projects starting right now. The recovery speed is continuously improving, and the estimated completion time is decreasing as we scale resources.
The remaining reindexing mainly affects TM units in segments in older projects. It should not block assignment workflows once the main performance issues are resolved.
Posted Apr 13, 2026 - 16:00 UTC
Update
We are continuing to investigate this issue.
Currently experiencing issues affecting several areas of the platform
- Task and Assignment Processing: Some users may encounter missing tasks in the assignment list.
- Team Member List: The team member list may not display correctly, or not be a full list
- Translation Memory Matches (TM): Display of TM matches may be inconsistent or incomplete in the CAT-Editor and concordance search.
Posted Apr 10, 2026 - 14:32 UTC
Investigating
We have encountered a problem in our platform that is hindering the access of our users to the platform. We are investigating the cause and actively working on restoring all functionality as soon as possible.
Furthermore, we’ll keep you updated on the progress and let you know as soon as everything is back to normal. Thank you for your patience and understanding.
Posted Apr 10, 2026 - 14:29 UTC
This incident affected: European region, American region, and Asian region.