File upload issue

Incident Report for Smartcat

Resolved

We have confirmed that the issue with file import and translation delays has been fully resolved. If you are still experiencing any difficulties, please don't hesitate to reach out.
Posted Jun 12, 2025 - 11:31 UTC

Monitoring

We are pleased to let you know that the issue affecting the speed of file upload and translation has been resolved by our team. We will continue closely monitoring the performance for a short while just in case.
However, the platform should now work without any delays - if you are still experiencing any difficulties, please don't hesitate to reach out.
Posted Jun 12, 2025 - 10:39 UTC

Investigating

We’re currently experiencing an increased load on the system, which is affecting overall performance. As a result, certain functionalities — such as uploading documents and initiating AI translation — may take significantly longer than usual.
You may notice that uploaded documents remain at the "extracting text" stage for an extended period, or that AI translation is delayed.
Our team is actively monitoring the situation and working to stabilize performance as quickly as possible. We appreciate your patience and understanding.
Posted Jun 12, 2025 - 10:17 UTC
This incident affected: European region, American region, and Asian region.